网站首页
docker下php容器 curl本机无法访问【curl: (7) Failed to connect to x.x.x.x port 80: Host is unreachable)】
问题描述:
centos 7.9 服务器上 使用docker容器部署了php环境,但是使用curl的时候 ,访问其他机器ip正常,但是curl本机ip 出现 curl: (7) Failed to connect to x.x.x.x port 80: Host is unreachable)的错误,经过几番折腾,各种技术论坛,百度等搞了好久终于找到了解决方案,解决方案如下:
执行如下两行命令即可解决问题
firewall-cmd --permanent --zone=trusted --change-interface=docker0
firewall-cmd --reload 相关推荐
-
php7下安装event扩展
一·、安装支持库libevent,需要编译高版本(这里以最新版本release-2.1.8-stable为例)1. wget -c https://github.com/libevent/libevent/releases/download/release-2.1.8-stable/libevent...
-
centos7 docker 安装配置nginx
第一步:docker pull nginx第二步:宿主机文件映射Nginx里的配置访问页面目录位置 /data/nginx/html主配置文件nginx.conf位置 /data/nginx/nginx.confnginx.conf文件内容###################user ...
-
Linux内核调优(大并发场景下)
为了让系统能够支持更大的并发,除了必须安装event扩展(或libevent扩展)之外,优化linux内核也是重中之重,以下优化每一项都非常非常重要,请务必按逐一完成。打开文件 /etc/sysctl.conf,增加以下设置#该参数设置系统的TIME_WAIT的数量,如果超过默认值则会被立即清除 ...
-
centos7 docker安装openjdk并运行jar包
第一步:docker pull openjdk第二步:创建一个java_app的数据卷 docker volume create java_app第三步:将jar包上传到/var/lib/docker/volumes/java_app/_data/下,然后启动镜像第四步:启动docker ...
-
centos7/linux 服务器 添加新硬盘并挂载
一、查看现有磁盘设备 fdisk -l 发现/dev/sdb 为新加的硬盘;二、开始分区 fdisk /dev/sdb fdisk -l #再次查看分区情况,已经有了/dev/sdb1三、创建文件系统,并格式化 mkfs.ext4 /dev/sdb1四、将新分区挂在到文件系统 mk...
-
centos7通过yum安装JDK1.8
安装之前先检查一下系统有没有自带open-jdk命令:rpm -qa |grep javarpm -qa |grep jdkrpm -qa |grep gcj如果没有输入信息表示没有安装。如果安装可以使用rpm -qa | grep java |&n...
-
11个代码质量审核和管理工具,程序员收藏
如今,代码质量分析和审核已成为每个企业的基本流程。随着开源代码库使用的增加,安全性和代码质量对于构建高质量软件至关重要。不良的代码不仅会影响代码的可维护性,而且还会在某些情况下影响其性能。此外,更好的代码质量还有助于企业将来减少维护和降低成本。幸运的是,有很多审核和管理代码的工具,为开发者和程序员提... -
编程的程序员们,你们有语言崇拜么?比如PHP是世界上最好的语言
有个有关程序员语言界的段子:问,你如何让一个论坛的人吵起来?答,PHP是世界上最好的语言。“PHP是世界上最好的语言”,虽然身在IT界,但说实话,这句话直到去年才明白,还是公司里招了个PHP程序员,问的他这句话到底是什么意思。大学中学的语言的话,FoxBase、C、C++,VB,Java,Ruby,...
php读取docx页码比较难操作,并且读取doc格式的页码数更难搞了,所以先将doc/docx/pp...
PHP是一种国内外流行的开源服务器端脚本开发语言。能适应大、中、小型项目的发展需要。PHP框架的真正...